Atlassian API Outage is affecting eSign functionality in Confluence

Incident Report for eSign Apps by Digital Rose

Postmortem

Atlassian did not raise an incident for this outage, but did share the following two change logs as part of root cause.

  • CHANGE-2520 - Deprecated REST API V1 endpoints removed from service (to be removed May 2025)
  • CHANGE-2763 - Deprecating V1s of content property Connect Javascript API methods (Announced Aug 2025 to be removed Feb 2026)

The Connect Javascript API was to be removed in 2026 but is dependent on the REST API that was to be removed in 2025. The two separate engineering teams scheduled these changes independently. This outage occurred when change 2520 was applied before 2763.

Posted Oct 01, 2025 - 23:44 MDT

Resolved

This incident has been resolved. The Atlassian Engineering team reverted the change to re-enable the API.
Posted Oct 01, 2025 - 00:30 MDT

Update

Atlassian has confirmed that the Engineering team reverted the change that caused the AP.confluence.getContentProperty API failure.

Will add a reference to the Atlassian incident ID once provided.
Posted Sep 30, 2025 - 22:00 MDT

Update

Continuing to monitor and wait for Atlassian response on the broken Confluence API: AP.confluence.getContentProperty.

For reference this is the formal deprecation announcement confirming the API was to be retired in February 2026: https://developer.atlassian.com/cloud/confluence/changelog/#CHANGE-2763
Posted Sep 30, 2025 - 13:31 MDT

Update

Several customers have confirmed standard operations have resumed (after clearing browser cache).
We are continuing to monitor for any further issues.
Posted Sep 30, 2025 - 05:49 MDT

Monitoring

As we have not received an update from Atlassian on when the failed API will be repaired, Digital Rose has developed a workaround for the API failure.
The workaround patch has been deployed to production, and is rolling out. It may take up to 12 hours for all user's browsers to refresh their caches to access the patch. If necessary you can force clear the browser cache.

Alternately, if Atlassian re-enables the API, the eSign app will resume working normally.
Posted Sep 30, 2025 - 03:33 MDT

Update

Atlassian has acknowledged the API change was made and has engaged the internal engineering team's escalation process.
Posted Sep 30, 2025 - 02:04 MDT

Update

We are continuing to investigate this issue.
Posted Sep 30, 2025 - 02:02 MDT

Investigating

A critical Atlassian API is failing, impacting eSign for Confluence functionality. First reported 11 PM Eastern.

Priority ticket has been escalated to Atlassian support.
Posted Sep 29, 2025 - 23:19 MDT
This incident affected: eSign for Confluence.